
 
 
 

Workshop 1 

Linear Static Analysis of a Cantilever Beam 

Copyright 2007 Dassault Systèmes Introduction to Abaqus  

Introduction 
In this workshop you will become familiar with the process of creating a model 
interactively by using Abaqus/CAE. You will create the cantilever beam model shown in 
Figure W1–1. 

 

Figure W1–1  Cantilever beam. 

Preliminaries 
1. Enter the working directory for this workshop: 

../IntroClass/Workshops/beam  

2. Start a new session of Abaqus/CAE using the following command: 

abaqus cae  

where abaqus is the command used to run Abaqus. 

3. Select Create Model Database from the Start Session dialog box. 

The Model Tree is located to the left of the toolbox area. If the Model Tree is not 
visible, make sure there is a check mark next to Show Model Tree in the View 

menu. If the Model Tree is still not visible, drag the  cursor from the left side 
of the Abaqus/CAE window to expand the Model Tree. The Model Tree provides 
a visual description of the hierarchy of items in the model database along with 
access to most of the model development functionality available in Abaqus/CAE. 
If you click mouse button 3 on an item in the tree, a menu appears listing 
commands associated with the item. For example, Figure W1–2 shows the menu 
for the Models container. In the Models menu, the Create menu item appears in 
bold because it is the default action that will be performed when you double-click 
the Models container.  
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Figure W1–2  Models menu. 

4. In the Model Tree, double-click Models to create a new model in the model 
database.  

The model attributes editor appears. 

5. In the Edit Model Attributes dialog box that appears, enter the name BEAM and 
click OK. 

The model BEAM appears in the Model Tree, as shown in Figure W1–3. The new 
model is underlined to indicate that it is a current object (i.e., BEAM is the model 
you are currently working on). 

Tip:  To reduce clutter in the Model Tree, collapse the container for Model-1 by 
clicking the “” sign next to the model name or set BEAM as the root. 



   

Copyright 2007 Dassault Systèmes Introduction to Abaqus  

W1.3 

 

Figure W1–3  Model Tree. 

6. To save the model database, select File→Save As from the main menu bar and 
type the file name BEAM in the Save Model Database As dialog box. Click OK. 

The .cae extension is added to the file name automatically. 

Creating a part 
In this section you will create a three-dimensional, deformable solid body by sketching 
the two-dimensional profile of the beam (a rectangle) and extruding it. 

1. In the Model Tree, double-click Parts to create a new part in the model BEAM.  
The Create Part dialog box appears.  

2. In the Create Part dialog box, name the part Beam, and specify an approximate 
size of 600. Accept the default settings of a three-dimensional, deformable body 
with a solid, extruded base feature. Click Continue. 

Abaqus/CAE displays text in the prompt area near the bottom of the window to 
guide you through the procedure, as shown in Figure W1–4. Click the cancel 
button to cancel the current task; click the backup button to cancel the current step 
in the task and return to the previous step. 
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Figure W1–4  Prompt area. 

The Sketcher toolbox appears in the left side of the main window, and the 
Sketcher grid appears in the viewport. 

3. To sketch the profile of the cantilever beam, you need to select the rectangle 
drawing tool, as shown in Figure W1–5. 

 

Figure W1–5  Rectangle sketch tool. 

4. In the viewport, sketch the rectangle using the following steps: 

a. You will first sketch a rough approximation of the beam and then use 
constraints and dimensions to refine the sketch. Select any two points as 
the opposite corners of the rectangle. 

b. Click mouse button 2 anywhere in the viewport to exit the rectangle tool. 

c. The Sketcher automatically adds constraints to the sketch (in this case the 
four corners of the rectangle are assigned perpendicular constraints and 
one edge is designated as horizontal). 

d. Use the dimension tool  to dimension the top and left edges of the 
rectangle. The top edge should have a horizontal dimension of 200 mm, 
and the left edge should have a vertical dimension of 20 mm. When 
dimensioning each edge, simply select the line, click mouse button 1 to 
position the dimension text, and then enter the new dimension in the 
prompt area. 

e. The final sketch is shown in Figure W1–6. 
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Figure W1–6  Sketch of the rectangle. 

5. Click Done in the prompt area to exit the sketcher. 
6. Enter an extrusion depth of 25 in the Edit Base Extrusion dialog box, and click 

OK. 
Abaqus/CAE displays an isometric view of the new part, as shown in Figure W1–
7. The Parts icon in the Model Tree changes to indicate that the model contains 
one part, . 

  

Figure W1–7  Extruded part. 

Creating a material definition 
You will now create a single linear elastic material with a Young’s modulus of 
209103 MPa and Poisson’s ratio of 0.3. 

To define a material: 

1. In the Model Tree, double-click Materials to create a new material in the model 
BEAM. 

Abaqus/CAE switches to the Property module, and the material editor appears.  

2. In the Edit Material dialog box, name the material Steel. Notice the various 
options available in this dialog box. 
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Figure W1–8  Pull–down menu. 

3. From the material editor’s menu bar, select Mechanical→Elasticity→Elastic, as 
shown in Figure W1–8. 

Abaqus/CAE displays the Elastic data form. 

4. Enter a value of 209.E3 for Young’s modulus and a value of 0.3 for Poisson’s 
ratio in the respective fields, as shown in Figure W1–9. Use [Tab] to move 
between cells, or use the mouse to select a cell for data entry. 

 

 

 

Figure W1–9  Material editor. 

5. Click OK to exit the material editor. 
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Defining and assigning section properties 
Next, you will create a homogeneous solid section and assign it to the beam. The section 
will refer to the material Steel that you just created. 

To define the homogeneous solid section: 

1. In the Model Tree, double-click Sections to create a new section in the model 
BEAM. 

The Create Section dialog box appears. 

2. In the Create Section dialog box: 

a. Name the section BeamSection. 

b. Accept the default category Solid and the default type Homogeneous. 

c. Click Continue. 

The solid section editor appears. 

3. In the Edit Section dialog box: 

a. Accept the default selection of Steel for the Material associated with the 
section. 

b. Accept the default value of 1 for Plane stress/strain thickness. 

Note: For three-dimensional solid geometry, this value is not used. It is 
only relevant for two-dimensional geometry. 

c. Click OK. 

To assign the section definition to the cantilever beam: 

1. In the Model Tree, expand the branch for the part Beam (click the “” symbol to 
expand the Parts container and then click the “” symbol next to the part Beam). 

2. Double-click Section Assignments to assign a section to the part Beam. 
Abaqus/CAE displays prompts in the prompt area to guide you through the 
procedure. 

3. Click anywhere on the beam to select the entire part as the region to which the 
section will be assigned. 

4. Click mouse button 2 in the viewport or click Done in the prompt area to accept 
the selected geometry. 

The section assignment editor appears. 

5. In the Edit Section Assignment dialog box, accept the default selection of 
BeamSection as the section definition, and click OK. 

Abaqus/CAE colors the beam green to indicate that the section has been assigned.  
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Assembling the model 
The assembly for this analysis consists of a single instance of the part Beam. 

To assemble the model: 

1. In the Model Tree, expand the branch for the Assembly of the model BEAM and 
double-click Instances to create a new part instance. 

Abaqus/CAE switches to the Assembly module, and the Create Instance dialog 
box appears. 

2. In the Create Instance dialog box, select Beam and click OK. 

Abaqus/CAE displays the new part instance in the viewport. 

Configuring the analysis 
In this simulation we are interested in the static response of the cantilever beam to a 
pressure load applied over the beam top. This is a single event, so only a single analysis 
step is needed for the simulation. Consequently, this model will consist of two steps: 

 An initial step, in which you will apply a boundary condition that constrains one 
end of the cantilever beam.  

 A general, static analysis step, in which you will apply a pressure load to the top 
face of the beam. 

Abaqus/CAE generates the initial step automatically, but you must create the analysis 
step yourself.  

To create a general, static analysis step: 

1. In the Model Tree, double-click Steps to create a new step in the model BEAM.  

Abaqus/CAE switches to the Step module, and the Create Step dialog box 
appears. 

2. In the Create Step dialog box: 

a. Name the step BeamLoad. 

b. From the list of available general procedures in the Create Step dialog 
box, select Static, General if it is not already selected. 

c. Click Continue. 

The step editor appears. 

3. In the Edit Step dialog box: 

a. In the Description field of the Basic tabbed page, enter Load the top 
of the beam. 

b. Click the Incrementation tab, and delete the value of 1 that appears in the 
Initial text field. Type a value of 0.1 for the initial increment size. 

c. Click the Other tab to see its contents; you can accept the default values 
provided for the step. 

d. Click OK to create the step and to exit the step editor. 
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Applying a boundary condition and a load to the model 
Next, you will define the boundary condition and loading that will be active during the 
BeamLoad step. 

To apply boundary conditions to one end of the cantilever beam: 

1. In the Model Tree, double-click BCs to create a new boundary condition in the 
model BEAM.  

Abaqus/CAE switches to the Load module, and the Create Boundary Condition 
dialog box appears. 

2. In the Create Boundary Condition dialog box: 

a. Name the boundary condition Fixed. 

b. Select Initial as the step in which the boundary condition will be activated. 

c. In the Category list, accept the default category selection Mechanical. 

d. In the Types for Selected Step list, select Displacement/Rotation as the 
type. 

e. Click Continue. 

Abaqus/CAE displays prompts in the prompt area to guide you through 
the procedure. The face at the end of the cantilever beam will be fixed. 

3. Click the Show/Hide Selection Options icon  in the prompt area to open the 

Options dialog box. Deselect Select the Entity Closest to the Screen  in 
the Options dialog box so that you can pick the desired face, as shown in 
Figure W1–10. 

  

Figure W1–10  Fixed end. 

If you click when the selection is ambiguous, Abaqus/CAE will select the face 
closest to you and display buttons in the prompt area that allow you to choose the 
required face. To cycle through the valid selections, do the following: 

a. From the prompt area, click Next or Previous until the desired face is 
selected. 

b. Click OK to accept the current selection. 

4. Click mouse button 2 in the viewport or click Done in the prompt area to accept 
the selected geometry. 
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The Edit Boundary Condition dialog box appears. When you are defining a 
boundary condition in the initial step, all six degrees of freedom are unconstrained 
by default. 

5. In the Edit Boundary Condition dialog box: 

a. Toggle on U1, U2, and U3, since only the translational degrees of freedom 
need to be constrained (the beam will be meshed with solid elements 
later). 

b. Click OK to create the boundary condition definition and to exit the editor. 

Abaqus/CAE displays arrows at each corner and midpoint on the selected face to 
indicate the constrained degrees of freedom, as shown in Figure W1–11. 

To apply a load to the top of the cantilever beam: 

1. In the Model Tree, double-click Loads to create a new load in the model BEAM. 

The Create Load dialog box appears. 

2. In the Create Load dialog box: 

a. Name the load Pressure. 

b. Select BeamLoad as the step in which the load will be applied. 

c. In the Category list, accept the default category selection Mechanical. 

d. In the Types for Selected Step list, select Pressure. 

e. Click Continue. 

Abaqus/CAE displays prompts in the prompt area to guide you through the 
procedure. 

3. In the viewport, select the top face of the beam as the surface to which the load 
will be applied. The desired face is highlighted in Figure W1–11. 

 

Figure W1–11  Fixed boundary conditions; face for distributed load. 

4. Click mouse button 2 in the viewport or click Done in the prompt area to indicate 
that you have finished selecting regions. 

5. In the Edit Load dialog box: 

a. Enter a magnitude of 0.5 for the load. 
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b. Accept the default Amplitude selection (Ramp) and the default 
Distribution (Uniform). 

c. Click OK to create the load definition and to exit the editor. 

Abaqus/CAE displays downward–pointing arrows along the top face of the beam 
to indicate the load is applied in the negative 2–direction. 

Meshing the model 
You use the Mesh module to generate the finite element mesh. You can choose the 
meshing technique that Abaqus/CAE will use to create the mesh, the element shape, and 
the element type. Abaqus/CAE uses a number of different meshing techniques. The 
default meshing technique assigned to the model is indicated by the color of the model 
when you enter the Mesh module; if Abaqus/CAE displays the model in orange, it cannot 
be meshed without assistance from the user. 

To assign the mesh controls: 

1. In the Model Tree, double-click Mesh in the branch for the part Beam.  

Abaqus/CAE switches to the Mesh module and displays the part Beam. 

2. From the main menu bar, select Mesh→Controls. 

3. In the Mesh Controls dialog box, accept Hex as the default Element Shape 
selection. 

4. Accept Structured as the default Technique selection. 

5. Click OK to assign the mesh controls and to close the dialog box. 

To assign an Abaqus element type: 

1. From the main menu bar, select Mesh→Element Type. 

2. In the Element Type dialog box, accept the following default selections that 
control the elements that are available for selection: 

 Standard is the default Element Library selection. 

 Linear is the default Geometric Order. 

 3D Stress is the default Family of elements. 

3. In the lower portion of the dialog box, examine the element shape options. A brief 
description of the default element selection is available at the bottom of each 
tabbed page. 

4. In the Hex tabbed page, select Incompatible modes. 

A description of the element type C3D8I appears at the bottom of the dialog box. 
Abaqus/CAE will now mesh the part with C3D8I elements. 

5. Click OK to assign the element type and to close the dialog box. 

To mesh the model: 
1. From the main menu bar, select Seed→Part to seed the part. 
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The Global Seeds dialog box appears. The default global element size is based 
on the size of the part. 

2. In the Global Seeds dialog box, enter an approximate global size of 10 and click 
OK. 

Abaqus/CAE applies the seeds to the part, as shown in Figure W1–12. 

 

Figure W1–12  Seeded part instance.  

3. From the main menu bar, select Mesh→Part to mesh the part. 

4. Click Yes in the prompt area or click mouse button 2 in the viewport to confirm 
that you want to mesh the part instance. 

Abaqus/CAE meshes the part instance and displays the resulting mesh, as shown 
in Figure W1–13. 

 

Figure W1–13  Part instance showing the resulting mesh.  

Creating and submitting an analysis job 
The definition of the model BEAM is now complete. Next, you will create and submit an 
analysis job to analyze the model. 

To create and submit an analysis job: 

1. In the Model Tree, double-click Jobs to create a new analysis job. 

Abaqus/CAE switches to the Job module, and the Create Job dialog box appears. 

2. In the Create Job dialog box, name the job Deform and select the model BEAM. 
Click Continue. 
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The job editor appears. 

3. In the Description field of the Edit Job dialog box, enter Workshop 1. 

4. Click the tabs to see the contents of each folder of the job editor and to review the 
default settings. Click OK to accept the default job settings. 

5. In the Model Tree, expand the Jobs container and click mouse button 3 on the 
job Deform. 
The menu for the job Deform appears. 

6. From the job menu, select Submit. 

The icon for the job will change to indicate the status of the job in parenthesis 
after the job name. As the job runs the status Running will be shown in the 
Model Tree. When the job completes successfully, the status will change to 
Completed, as shown in Figure W1–14. 

 

Figure W1–14  Job status in the Model Tree.  

Viewing the analysis results 
You are now ready to view the results of the analysis in the Visualization module. 

1. In the Model Tree, click mouse button 3 on the job Deform and select Results 
from the menu that appears. 

Abaqus/CAE switches to the Visualization module, opens the output database 
created by the job (Deform.odb), and displays the undeformed shape of the 
model, as shown in Figure W1–15. 

 

Figure W1–15  Undeformed model shape.  

2. In the toolbox, click  (or select Plot→Deformed Shape from the main menu 
bar) to view a deformed model shape plot, as shown in Figure W1–16. 
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Figure W1–16  Deformed model shape.  

You may need to use the Auto-Fit View tool  to rescale the figure in the 
viewport. 

3. In the toolbox, click  (or select Plot→Contours→on Deformed Shape from 
the main menu bar) to view a contour plot of the von Mises stress, as shown in 
Figure W1–17. In this figure, the font size for the legend text has been increased 
to 10 (Viewport→ Viewport Annotation Options). 

 

Figure W1–17  Mises stress contour plot. 

4. In the toolbar, click  (or select File Save from the main menu bar) to save 
your model in a model database file. Close the Abaqus/CAE session by selecting 
File Exit from the main menu bar. 

5. Rename the abaqus.rpy replay file BEAM.rpy. Start a new Abaqus/CAE 
session, and execute the replay file using the command 

abaqus cae replay=BEAM.rpy 
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Commands issued during the previous Abaqus/CAE session are executed 
automatically through the replay Python script. Close the Abaqus/CAE session by 
selecting File→Exit from the main menu bar. 

6. Start a new Abaqus/CAE session, and rebuild the BEAM.cae model database 
using the command 

abaqus cae recover=BEAM.jnl 

Only the commands necessary to rebuild the model database BEAM.cae are 
executed. 


